Home

This Richporter Distributor - Part No

Richporter Technology HT28 Distributor

Too low to display


Rich Porter Technology Indianapolis Indiana Distributor - TBA

A: No Morgan, This Richporter Distributor - Part No. VW10 Does NOT have the replacement cap and rotor and it can NOT be purchased separately. Did you bother checking the A.A.P. system for a part number before answering that question? Obviously not or you'd have found that you have no listing for a replacement cap or rotor for the VW10. You guys sell the distributor but can't get the customer a replacement cap and rotor when the one that comes with it wears out. Apparently the manufacture figures you can just replace the entire distributor if the cap or rotor wears out.

A: With reference to your inquiry on the Richporter Distributor - part# VW10, we request you to call us directly at 1-877-ADVANCE (238-2623) and we would be glad to verify this price match request and if it is valid, we would be glad to match the price and assist you in placing the order online and have it picked up at your local store.

Spectra Premium Distributor VW10: Advance Auto Parts

Richporter SVDA Distributor
Page: 1, 2, 3, 4  Next

Cheap discount Richporter technology wholesale product shop on sale.

CORVETTE / LT1 FORUMS:

Hi, I'm having a problem with the optispark distributor on a 1994 Corvette. I changed my original distrubutor to a MSD brand and had a problem, I replace the MSD with a RichPorter Tech distributor and the new distributor did not work and it gave a code 16....low resolution, I returned that distributor and the parts store gave me another RichPorter distributor and this one also states code 16. Any ideas as to what the problem could be?

UPDATE UPDATE UPDATE UPDATE:

Hi, yea, I figured out the problem, I was getting a code 16 "low resolution" and it turned out NOT to be the opti-spark....I had a new MSD opti on there and thought it was broke, I then installed another opti RichPorter and it did not work so, I brought that opti back and they gave me another opti and it did not work!! So, it got me thinking more, when a true code 16 exist the car should not have spark or fuel pressure but, my car did which turned out to be a intermittent code 16, I checked all the wiring harnesses for rips and found none, I then checked all the voltage/ground readings on the opti harness/coil and everything was good but, still having a code 16 problem, I posted this on the Corvette Forum and a guy told me to check my body ground straps....especially the ground strap on a vette that runs under the brake booster and goes to the bottom of the car....I WIGGLED THE GROUND STRAP AND THE CAR STARTED RIGHT UP WITHOUT HESITATION!!!! So, turned out to be a body ground strap which ties into the computer ground which was making the computer give a false code 16! What a PITA but, easy fix....after changing opti 3 times LOL...dam! So, if your not sure it's the opti, check the voltage on the opti harness, i think the four plugs should read 5/5/12/ground....check this on both the harness where it connect near the fuel injectors and then check the other side of the harness by unplugging harness from opti and check that side and should be the same readings if all that checks out ok, it may be the opti but, this tricked me so, then put a spark tester on the plug/wire and see if your getting spark...if your still getting spark it is then a bad body ground or a bad computer....check all the grounds first and then move onto the computer. The opti is really simpler then it appears, the problem will be with the opti or wiring harness or grounds and finally the computer....NOTHING else is intertwined with it to cause a failure so, the problem will be one of those areas....good luck! There is lots of info at the different forums: